Archive of UserLand's first discussion group, started October 5, 1998.

filemaker transactions problems with Frontier

Author:R.T. Weber
Posted:10/15/1999; 1:25:09 PM
Topic:filemaker transactions problems with Frontier
Msg #:12077
Prev/Next:12076 / 12078

Has anyone had problems trying to run multiple transactions with frontier scripts? I want to run several scripts similar to the one below in sequential order. I can run each one independently with no issues but if I call them in order from another script, I get the error:

"Filemaker" reported the following error: "No user interaction allowed"

I've tried verbs like filemaker.close (), filemaker.endtransaction (), even filemaker.quit () between the scripts. I've also tried adding a clock.waitseconds (60) to allow for any delays and I still get the error. One last note to add is that the error does not occur if the sequential script does a find in the same db. It only occurs when a new db has to be opened.

Any ideas?

on findAs () { with filemakerLib { bringToFront ("filemaker"); local (db = "DVDit! Bug Database", ct); (db); findAll (db); find (db, {"open", "A-Fix Immediately"}, {"", "Fix Priority"}); sendToBack (); Frontier.bringToFront (); ct = countRecords (db); local (i, devName); new (tableType, @temp.devCounters); for i = 1 to ct { devName = getCellNthRecord (db, "Claimed By", i); if devName == "" { devName = "Unclaimed"}; msg ("Record " + i + ": " + devName); if not defined (temp.devCounters.[devName]) { temp.devCounters.[devName] = 1} else { // we know who this is already temp.devCounters.[devName]++}}; tcp.sendMail ("", "New Bugs - DVDit!", "There are " + ct + " 'A' bugs open for all developers", "RT")}}; findAs ()

There are responses to this message:

This page was archived on 6/13/2001; 4:53:04 PM.

© Copyright 1998-2001 UserLand Software, Inc.