Archive of UserLand's first discussion group, started October 5, 1998.

Re: betty error - POST malformed
Posted:2/26/2000; 1:34:11 AM
Topic:betty error - POST malformed
Msg #:15268 (In response to 15240)
Prev/Next:15267 / 15269

Good morning in California (afternoon in M'sia)

I tried many things to get XML-RPC working without success till I got fed up and did a clean install of frontier 6.1.1 again. I did not connect to because the remote configuration doesn't work from behind the firewall.

Then I tested the following code and it worked correctly:

 local (params = {18, 31, 2, 44});
 s=betty.rpc.client( procedureName:"examples.getStateNames",  adrparamlist:@params, fldebug:true); //runs on localhost

Great, XML-RPC works in a plain vanilla install with NO guest databases. Then I followed the README.html instructions to add the following commands to frontierStartupCommands.txt. (The following proxy commands are correct - because I can update my root from thru the firewall)

new (tableType, @user.webBrowser.proxy);
user.webBrowser.proxy.domain = "";
user.webBrowser.proxy.port = 8080;
user.webBrowser.proxy.username = "";
user.webBrowser.proxy.password = "";

I run the same betty.rpc.client() script above. This time I get an error info dialog stating:

Can't get the address of "methodResponse" 
because the table doesn't have an object with that name.

The html returned by frontier to the XML-RPC request is:

HTTP/1.1 500 Server Error
Connection: close
Content-Length: 177
Date: Sat, 26 Feb 2000 09:14:42 GMT
Server: UserLand Frontier/6.1.1-Win95

500 Server Error Can't call the script because the name "mainResponder" hasn't been defined


My guess is that the proxy server code needs some debugging, and there are dependencies requiring mainResponder.root (which I had not opened). The problem is probably somewhere deep down in webserver.server(); incidentally, manila is working fine, only XML-RPC is giving problems.

Another possible cause is that the install instructions for operation behind a proxy server have missed out something.

That's about all I can find out. I hope userland can fix this problem. Temporarily, I can run Frontier outside the firewall as a workaround, but not for long.

There are responses to this message:

This page was archived on 6/13/2001; 4:54:25 PM.

© Copyright 1998-2001 UserLand Software, Inc.