Archive of UserLand's first discussion group, started October 5, 1998.

% sign in password prevents membership from working

Posted:6/16/1999; 4:17:54 PM
Topic:% sign in password prevents membership from working
Msg #:7474
Prev/Next:7473 / 7475

I'm using the more varied password generator string.getRandomPassword() which kicks out symbols, numbers, and/or letters. This is fine except that I hear from some users who cannot login after signing up using the standard Frontier 6 membership schema, and get the "the password is incorrect." message. So I tried deleting various characters out of the random password ")8%=C]Js" and lo-and-behold, it worked once I got rid of the % sign. However if the % sign is ther last character, then it works. Wierd or what!? I can't go back to the stock simple password generator because company policy requires passwords to have at least upper, lower case, and either a number or symbol. So I guess I'm going to have to examine the output of getRandomPassword for "%". Any other characters I should be concerned about?

This page was archived on 6/13/2001; 4:50:51 PM.

© Copyright 1998-2001 UserLand Software, Inc.